Announcement

Collapse
1 of 3 < >

Help with the downloadable games

If a downloadable game is an .exe file, just click the link, and choose open. The game will usually be installed among your other programs (otherwise you can choose where you would like to install it during the installation process).

If the game is a .zip or .rar file, choose save, and save it to your pc.
Extract it in a new folder using WinRar for example (if you don't have it, get it from here: http://www.rarlab.com/).
Then click the installation file (in most cases .exe file) or the file that starts the game, and your pc will install it, or launch it respectively.
2 of 3 < >

Game Loading Problems

First Check to make sure you have all the latest Plugins. They are free updates to your computer that allows you to play the games. They will not hurt your computer. They just allow you to play our games.

Here's what you need:

For Java: http://www.java.com/en/download/windows_ie.jsp

For Flash: http://www.adobe.com/products/flashplayer/

For Shockwave: http://sdc.shockwave.com/shockwave/download/download.cgi

We highly recommend you are up to date on all of them so you can play all the games here.

If you are still having problems please post what the problem is HERE
3 of 3 < >

Rules updated

Old members and new members, please read the updated rules.
You find them as sticky at the top of all forum categories, for example here:
http://gamershood.com/forum/showthread.php?t=1603
Thank you for taking a couple of minutes to do that.

The moderation team
See more
See less

Hyouseki - Ice Stone Escape

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hyouseki - Ice Stone Escape

    Hyouseki - Ice Stone Escape is another Japanese point and click room escape game developed by Strawberry Cafe. In this game, you are locked in an room and you have to search the room to find items and some clues for solving puzzles and escaping from the room.

    http://strawberrycafe.haru.gs/hyouseki.html


    Please use spoilers to give hints:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for at least 7 days.

  • #2
    opened everything
    stuck with

    out
    got happy end

    Comment


    • #3
      This game just LOOKS easy. I have
      I'm still fooling around with the shapes code (which I bet is simple) but I haven't figured it out yet. Sorry I can't be of help (yet) Old Biker.

      Officially, undeniably stuck
      Last edited by slerk; 11-01-2010, 17:53:07.

      Comment


      • #4
        its not that hard ,i got stuck on the most obvious thing (red cristal)
        but out now ,and as usual ,fantastic game
        for 3 numb.code


        for the periscope ,its


        gonna post some games ,i ll be around for help

        Comment


        • #5
          Thanks, Old Biker. I swear I tried that with the 3 number code. Grrr. Anyway, it worked this time.


          EDIT: Phew...finally out.


          I loved the sound of the bells.
          Last edited by slerk; 11-01-2010, 18:35:09.

          Comment


          • #6
            good thing

            Comment


            • #7
              Darn, missing the lavender crystal, gotta go back and look for a hint

              Okay, the hint is not here

              Found it
              sigpic


              Strange as Angels, Dancing in the Deepest Oceans

              Comment


              • #8
                Clever game and the box puzzle has me stumped even tho I've studied the cactus plate. Any clues available? Unfortunately the box I was given only does x's. Tnx anyway. ;}
                Last edited by kitsy71; 11-03-2010, 21:45:20.

                Comment


                • #9
                  Originally posted by kitsy71 View Post
                  Clever game and the box puzzle has me stumped even tho I've studied the cactus plate. Any clues available?
                  sigpic


                  Strange as Angels, Dancing in the Deepest Oceans

                  Comment


                  • #10
                    Okay, I only have 3 crystals and no idea where to look for the others.
                    Have solved the 2 number codes and the colorcode.
                    Saw a hint on the window but I don't get it yet.
                    Don't know about what kind of box kitsy71 is talking, I haven't seen a box
                    Have seen a key on the table with the bell thingy but I can't get it.

                    Have some other item in inventory that I haven't used and I don't know what's it for.

                    POP
                    Finally got the key, I thought that I had tried that already

                    Out with happy end....I was wondering why that big thing was there.....hehe now I know
                    From now on, this is how it is going to be, just her and me
                    sigpic

                    Comment


                    • #11
                      I think I had a bug in this game. Opened the cabinet with the round key and found nothing in it. After playing for another frustrating half hour (stuck!) I gave up, read the walkthrough which told me there was a hammer and a puzzle in that cabinet. Restarted the game and found them. Out!

                      Comment

                      Working...
                      X