No announcement yet.

Escape From The Mayan City

  • Filter
  • Time
  • Show
Clear All
new posts

  • Escape From The Mayan City

    You have been informed that there is a treasure in the temple. Find items and clues, and solve puzzles to find the treasure, good luck!

    Play Here

    Please use spoilers for hints and walkthroughs:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for 7 days.

  • #2
    Found lever and used it.
    Also have 2 coins and 3 masks. I think I need one more mask.

    Okay got all 4 masks and used them. Received a red gem (I think it is a gem).

    Used gem, but need more of them.

    Used 2 coins
    Found a statue (used) and a red (or rusty?) coin (used).
    Got stone tile thingy.
    Used stone tile, and got second rusty coin.

    And finished


    • #3
      Done...Pretty simple game...wish I could turn the music off however


      • #4
        All I have found is one Timdogg mask, but I will continue with out looking at hints

        Strange as Angels, Dancing in the Deepest Oceans


        • #5
          LOL, a Timdogg mask

          I personally liked the music, but that's always a question of personal taste


          • #6
            Is the lever at the bottom of the tree (cuz, mine isn't clickable) 3 masks and one coin, all used. Stuck


            • #7
              No, it's not there.

              Look there


              • #8
                Oh, I think I already had that... did it look like a white femur bone ??!


                • #9
                  Have you ever tried the combinaton - right click and play....


                  • #10
                    Originally posted by donaud View Post
                    Oh, I think I already had that... did it look like a white femur bone ??!
                    Yes, this is it

                    Originally posted by huggy View Post
                    Have you ever tried the combinaton - right click and play....
                    Lol, no - but that's never a satisfactory way to finish a game for me


                    • #11
                      my screen all of a sudden went black with a mask moving around. when it landed under "walkthrough" I couldn't click on it or it would bring a page with a walkthrough. ???? will try again!

                      too hard to find things,,,,,done!
                      Last edited by jgarrah; 12-11-2010, 16:22:48.


                      • #12
                        Sorry to hear that you have experienced a bug - I had no issues.
                        Good luck that you can get through next time


                        • #13
                          yes, a bit hard to find things----

                          and i found the treasure-- congrats ? shoot, wanted a Gongtat
                          Last edited by BchBum; 12-11-2010, 20:29:43.

                          enjoy life


                          • #14
                            Need the second gem and have both (rusty) coins, as Mistery calls them. No idea where to place them. Tried the cave again but that isn't going to work for the second time
                            Okay, looks like I missed a view.
                            Congrats, the treasure is mine
                            From now on, this is how it is going to be, just her and me


                            • #15
                              and out. That felt like a Captain Planet ending.. The Treasure is yours!