1 of 3 < >

Help with the downloadable games

If a downloadable game is an .exe file, just click the link, and choose open. The game will usually be installed among your other programs (otherwise you can choose where you would like to install it during the installation process).

If the game is a .zip or .rar file, choose save, and save it to your pc.
Extract it in a new folder using WinRar for example (if you don't have it, get it from here:
Then click the installation file (in most cases .exe file) or the file that starts the game, and your pc will install it, or launch it respectively.
2 of 3 < >

Game Loading Problems

First Check to make sure you have all the latest Plugins. They are free updates to your computer that allows you to play the games. They will not hurt your computer. They just allow you to play our games.

Here's what you need:

For Java:

For Flash:

For Shockwave:

We highly recommend you are up to date on all of them so you can play all the games here.

If you are still having problems please post what the problem is HERE
3 of 3 < >

Rules updated

Old members and new members, please read the updated rules.
You find them as sticky at the top of all forum categories, for example here:
Thank you for taking a couple of minutes to do that.

The moderation team
See more
See less

Kaito M Collection 04 Escape

  • Filter
  • Time
  • Show
Clear All
new posts

  • Kaito M Collection 04 Escape

    Kaito M Collection 04 Escape is another Japanese point and click, room escape game by Funkyland. Search for clue's and items, use them ,solve puzzles and escape

    Good luck


    Please use spoilers for hints and walkthroughs:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for 7 days.

  • #2
    I don't know how far I'll get in this game as I'm making some progress, but I have no clue as to what I'm doing...
    Have flashlight, camera/cell, now a box /w token. Opened gate and inside.

    Got gold 'thingy' from R/S room...unlocked token box.
    Placed camera in L/S room...can't seem to do anything...?
    Placed Token in keypad....but I don't know code...?
    Did something /w keypad; now have fingerprint...

    Now stuck....tried colours, shapes but it's always 4 and view is so small... it! Thought I'd try it one more time...good thing.
    Entered R/S numbers as per L/S clue and now have paper...

    Now have paper from L/S room.
    Keypad light is now green, but laser beams are still there...?
    I see keypad lights up, so I need a code....
    Entered shapes, colours...? I'm not getting it.... it, I'm out!
    That was tough, I had tried everything...then noticed keypad keys have colours.
    Last edited by graywolf; 04-28-2013, 17:37:53.