No announcement yet.

Old Room

  • Filter
  • Time
  • Show
Clear All
new posts

  • Old Room

    Old Room is another point and click, room escape game. Search for items and clue's . Solve puzzles and escape

    Good luck


    Please use spoilers for hints and walkthroughs:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for 7 days.

  • #2
    out with normal end ,prety hard game


    • #3
      out with true end...fascinating game....

      A student who changes the course of history is probably taking an exam.

      As long as the answer is right, who cares if the question is wrong?


      • #4
        Great game, hard

        True end!

        Strange as Angels, Dancing in the Deepest Oceans


        • #5
          Have...magnifier, paper, paper scrap, candle and poker.
          I see what I think is a dictionary; I hope Japanese is not needed(?).
          I need a 4-digit combo, key for mini drawer and box code.

          Found key; now in storeroom.

          Aha...I also see something else and I now have 2 letters

          Letters didn't do what I thought.
          Lit fire, now have 5 digits, they didn't go where I what?

          Searching and checking for other views; I think I'm stuck...
          Found other item, not sure what to do with it?

          I had to seek help; digits are not digits...used dictionary and now have key from box.

          1st symbol on box was not what I saw..tried another and it worked. Now have key.

          Unlocked mini cabinet and now have pic. Now have combo and another key.

          Now in new room. Have 2 more letters, I see I need 6.
          Found 2 more items and I see 'x' marks the spot.
          Used glass, and now have another view and another letter.

          Searching and I see another letter.

          Trying letters; no luck (I'm terrible at scrambled letters)...looked at paper clue, and I got it; now have small box and another picture.

          Modified the box and attached....I guess it's a weight.
          Bookcase opened and I said 'yes' and said 'escape failure'-'normal end'...?
          I hadn't used pic let me go back (clicked hotspot text) to replay from where I was before exiting....
          Searching....I see clue but I'm stumped!

          I had to get help from E24...but I do not understand their explanation.
          I entered last 'word' and got a true end...but reasoning makes no sense!

          Excellent game up until 'normal' end.
          Last edited by graywolf; 06-17-2013, 18:30:08.