Announcement

Collapse
No announcement yet.

Chicka episode-11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chicka episode-11

    Chicka episode-11 is another Japanese point and click, room escape game from Pixelkobo. Roam trough the rooms looking for for hints and clue's, solve puzzles and get out

    Good luck

    play

    Please use spoilers for hints and walkthroughs:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for 7 days.


  • #2
    Stuck in the third room, totally missing clues somewhere??

    sigpic


    Strange as Angels, Dancing in the Deepest Oceans

    Comment


    • #3
      Third room what is there?

      I think i know




      A student who changes the course of history is probably taking an exam.

      As long as the answer is right, who cares if the question is wrong?



      Comment


      • #4
        And I made it out
        sigpic


        Strange as Angels, Dancing in the Deepest Oceans

        Comment


        • #5
          wow...i´m out without any help...

          Comment


          • #6
            hanging over a cliff

            Comment


            • #7
              Into door1, stuck on door2...see clues, not getting order clue.
              Of course, it's shape direction, not position direction.
              Stuck again...I'll have to pass this game as I'm not getting it.
              And then I see the code in the door hole....through door3...
              Crossed bridge, pulled lever in cabinet....see door.
              Crossed from bridge and into new passage (2 clues...?). Can't seem to p/u items from floor.
              Had to go back to get green block clue from previous passage window.
              Pressed green blocks & ctr, and something happened.
              Also entered L/R on exit of passage, but nothing...smll trap door still doesn't open? Got it!

              Went back and nothing...need to press trap door button, then green block button to get new passage.
              See waterfall and symbol...no idea what to do. Oh I see....look at stepping stones.
              Set stones, but waterfall looks the same and door /w round symbol still doesn't open...?
              "Finally" got it...out the 'round' symbol door and out.
              Last edited by graywolf; 10-06-2014, 19:11:32.

              Comment

              Working...
              X