Announcement

Collapse
No announcement yet.

Escape from new house

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Escape from new house

    Escape from new house is a new Japanese point and click, room escape game by busosobu. Solve puzzles, find clue's and items in order to escape the room.

    Good luck

    Play

    Please use spoilers for hints and walkthroughs:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for 7 days.


  • #2
    That was not easy.








    A student who changes the course of history is probably taking an exam.

    As long as the answer is right, who cares if the question is wrong?



    Comment


    • #3
      Have flashlight, battery, diamond card and some black thing (know idea what it is?).

      I'm guessing I need 2 batteries as battery won't go in flashlight, and I also need a number to set the time...
      Turned breakers on.
      Solved the clock, now have paper /w some numbers.
      Found spot to use flashlight and now see a clue.
      Found heart card and now trying to figure out TV...?
      Found club card; now to find spade...
      Found pants and now have key.
      Used key and now see a safe. Need to find the spade card...
      I still have no idea what black thing is and what to do /w battery..?
      Fiddling around TV trying to figure it out....Aha! Found spade card!
      I think there is a BUG!!!....Went back in double door closet room (should be noted 1st time in that room there was not a closet, but 2nd time there was a 4-door closet in the double door room) and now I am stuck in there and cannot back out....?
      FINALLY....that took a bunch of clicking all directions and playing /w closet doors. Definite bug!
      Back to safe; entered combo and now have 2nd battery and remote.
      Set TV to wall clue, but still fuzzy.... Aha, now see numbers!
      Front door now works; entered combo, but no luck...
      Maybe I have to still use the back thing somehow...?
      Searched, came back to door and it opened (maybe had to unzoom to open???)...now out /w trueend.
      What was the black thing for???
      Nice game except for bug.
      I watched a video to see what black thing was for....there are different ends as it showed doing something else /w remote and then the sink opens (no idea what clue for it is?)...still no clue on black thing...?

      Comment


      • #4
        I started this this morning, the navigation is a little rough

        Flash crashed
        sigpic


        Strange as Angels, Dancing in the Deepest Oceans

        Comment

        Working...
        X