No announcement yet.

Village Escape - Part 4

  • Filter
  • Time
  • Show
Clear All
new posts

  • Village Escape - Part 4

    The next episode in the Village Escape series by 123bee has been released.
    This time, the prestigious crown is stolen and a boy is kidnapped at the village. Assist the hero of the village in this rescuing act by finding objects and using them accordingly to escape. An exciting prospect at hand!

    Play Here

    Please use spoilers to give hints:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for 7 days.

  • #2
    Tried to play this. Maybe I'm doing something wrong but once I

    Very frustrating

    Players on other sites don't seem to be having trouble. Must be me!

    Maybe I'll try later.
    Come on, get happy!


    • #3
      Looks like fun but seems a bit glitchy
      My biggest peeve is the arrows...I'm having to hunt for the "go back" arrows which is kind of frustrating...
      Will try again later...Thanks for posting!


      • #4
        Hmmm....little stuck now...

        Nevermind out...
        Last edited by Michelle; 08-28-2009, 18:09:09.


        • #5
          Well, you all got further than I have
          - I've seen the dog and the big guy. Moving about it rough.
          At last used those items and now have something else ..
          Can't seem to interest man or cat in my item. No close up of goats.
          Last edited by NannaJoy; 08-28-2009, 18:55:10.


          • #6
            Are you still there NannaJoy?

            Are we supposed to feed the fish to the cat? This game is soooo glitchy, I really don't know when I'm doing something wrong. Yeesh.

            NVM. I found out the answer

            Aaaaargh. I must have done something wrong and I now I have to find that crotchedy pixel AGAIN!
            Last edited by slerk; 08-28-2009, 19:00:00. Reason: found answer


            • #7
              I'm still here - so what did you do w/ the fish? I tried the cat, man, well ..
              Heading to porch for a wicked evil smoke - but leaving page open. Maybe something will hit me while I'm out there.
              Back and still trying to figure it out.
              resorted to the walkthrough and will try that AGAIN
              Even knowing what to do took me over a minute to find THE SPOT
              and out
              but not a great game ..
              Last edited by NannaJoy; 08-28-2009, 20:50:20.


              • #8
                dont really like these games...
                My Motto:enjoy life and dare to dance like a PANDA!!!


                • #9
                  Pretty glitchy. I really had trouble with the cat.


                  • #10
                    not a very fun game. had trouble finding the back arrows. and the right spots for the dog and cat.