Announcement

Collapse
1 of 3 < >

Help with the downloadable games

If a downloadable game is an .exe file, just click the link, and choose open. The game will usually be installed among your other programs (otherwise you can choose where you would like to install it during the installation process).

If the game is a .zip or .rar file, choose save, and save it to your pc.
Extract it in a new folder using WinRar for example (if you don't have it, get it from here: http://www.rarlab.com/).
Then click the installation file (in most cases .exe file) or the file that starts the game, and your pc will install it, or launch it respectively.
2 of 3 < >

Game Loading Problems

First Check to make sure you have all the latest Plugins. They are free updates to your computer that allows you to play the games. They will not hurt your computer. They just allow you to play our games.

Here's what you need:

For Java: http://www.java.com/en/download/windows_ie.jsp

For Flash: http://www.adobe.com/products/flashplayer/

For Shockwave: http://sdc.shockwave.com/shockwave/download/download.cgi

We highly recommend you are up to date on all of them so you can play all the games here.

If you are still having problems please post what the problem is HERE
3 of 3 < >

Rules updated

Old members and new members, please read the updated rules.
You find them as sticky at the top of all forum categories, for example here:
http://gamershood.com/forum/showthread.php?t=1603
Thank you for taking a couple of minutes to do that.

The moderation team
See more
See less

Payne Escape

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Payne Escape

    Payne Escape is yet another room escape game by GazzyBoy. Your mission is to collect items, find clues and solve puzzles to escape the room!

    Payne Escape


    Please use spoilers to give hints:
    [spoiler=Title Here]Enter text here...[/spoiler]

    Please do not post a video walkthrough for 7 days.

    He who fights and runs away can run away another day.



  • #2
    Can`t get this game started. Bad link or am I doing something wrong?

    Edit; nevermind, didn`t see the "x" in the ad. I could'nt even escape the ad! Haha
    Okay, here we go!

    So far I found [spoiler=payne escape] device, fire-extinguisher, knife[spoiler]
    I put out the fire, cracked the elevatorcode, got in the elevator, got confused
    because as soon as I touched the keypad it said; under construction
    Then I died...

    Got up again, started over, maneged to get out of the elevator into a new room.
    Found pills

    Started up computer, zoomed in on tvscreen and now I'm stuck...

    Really annoying handling though, too much switching between hand and eye!

    Anybody else here? Would be nice to solve this together.

    OK, I used the red/pink pill

    pressed on the screen and got in some E.R. "doctor don't let me die" room.
    Found

    And dead again!!! Not funny anymore!

    Tried everything I could within the time I had, tried to combine stuff and so on. Zoomed in on the lamps and dead.
    Last edited by Adventure; 10-27-2010, 21:57:34. Reason: quintuple post. Check your PMs please.

    Comment


    • #3
      This game is driving me nuts!

      I'm as far as you are Bizzz,and I can't get any further.I've tried everything I can think of.This game is either buggy or just plain annoying!

      I'm giving up for a while,good luck to all who try this game.
      Last edited by tipper75; 10-28-2010, 11:30:53. Reason: Please do not double post, you can use the edit tab to add additional information to the original post.

      Comment


      • #4
        Don't like the navigation so I give.....
        From now on, this is how it is going to be, just her and me
        sigpic

        Comment

        Working...
        X