Announcement

Collapse
1 of 3 < >

Help with the downloadable games

If a downloadable game is an .exe file, just click the link, and choose open. The game will usually be installed among your other programs (otherwise you can choose where you would like to install it during the installation process).

If the game is a .zip or .rar file, choose save, and save it to your pc.
Extract it in a new folder using WinRar for example (if you don't have it, get it from here: http://www.rarlab.com/).
Then click the installation file (in most cases .exe file) or the file that starts the game, and your pc will install it, or launch it respectively.
2 of 3 < >

Game Loading Problems

First Check to make sure you have all the latest Plugins. They are free updates to your computer that allows you to play the games. They will not hurt your computer. They just allow you to play our games.

Here's what you need:

For Java: http://www.java.com/en/download/windows_ie.jsp

For Flash: http://www.adobe.com/products/flashplayer/

For Shockwave: http://sdc.shockwave.com/shockwave/download/download.cgi

We highly recommend you are up to date on all of them so you can play all the games here.

If you are still having problems please post what the problem is HERE
3 of 3 < >

Rules updated

Old members and new members, please read the updated rules.
You find them as sticky at the top of all forum categories, for example here:
http://gamershood.com/forum/showthread.php?t=1603
Thank you for taking a couple of minutes to do that.

The moderation team
See more
See less

Yamata no Orochi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Edited my post above. I'm kinda out, but dunno if that's good Probably not

    EDIT
    Ah, when I reply, I get to the snakes right away. So my ending was not good probably.
    Now let's see if there's a better way out. How to kill the snakes?

    Comment


    • #17
      Nope, I got out that way too and it isn't the right way. If you click on the blue button of the game twice you'll get back to the scene with the snakes.
      From now on, this is how it is going to be, just her and me
      sigpic

      Comment


      • #18
        Yup, just edited my post above again
        Let's kill those snakes!

        Comment


        • #19
          Yes, please do. I have been trying this for a very long time now but I have no idea how??
          From now on, this is how it is going to be, just her and me
          sigpic

          Comment


          • #20
            Well, throwing knives at the monitor doesn't help

            I think we need to combine the items, just how

            Does your green thingy also blink?
            Used

            Comment


            • #21
              Yes, I've done that too. Also tried to combine all the items but that isn't working either. If you click on shield to open it in other view and you click on it again, you can see the reflection of the Hero of the story but that is all I can do with it.
              All the other things weren't so hard to do so it must be something simple that we just don't get.
              I've tried to do as the hint on the wall says. First use sword, then green thingy, then sword again and then shield but it just isn't working.
              Tried to find other walkthroughs but the only one I found was a Turkish one and after translation, it still makes no sense to me.


              In the mean time, I am out of the Deluxe room
              From now on, this is how it is going to be, just her and me
              sigpic

              Comment


              • #22
                Hmmm, what are we missing
                In the meantime, we can read this
                http://en.wikipedia.org/wiki/Yamata_no_Orochi

                Comment


                • #23
                  Ugh... stuck here...

                  Progress... found
                  Last edited by SueJ999; 11-29-2010, 19:23:02.

                  Comment


                  • #24
                    Use sword

                    Comment


                    • #25
                      Any progress after that? Just have
                      and the guy's waving at me!

                      Clicked him enough times I had two choices.. one took me back in the game and the other thinks I'm done! Oh well... that's good enough for me!
                      Last edited by SueJ999; 11-29-2010, 19:30:24.

                      Comment


                      • #26
                        Yeah, that's how far we got, too.
                        According to the drawing on the cave, we now should be able to kill the snakes I think, but no idea how

                        Comment


                        • #27
                          used 5 things - still two in my items list. need a new view I think. Maybe a hint ..
                          Evidently out - 9315 is the posted # ? score. arrow pointing to unarmed fellow. Some how it doesn't seem like the right ending. Gal and guy should end up together ... Maybe that just happens in Snow White.
                          Redoing - appears to be something else in stream behind closest stone.
                          Used all but 3 things. My 5th spot is empty.

                          EDIT: ate, looked some more, calling it quits w/ unarmed fellow.

                          EDIT: popped by to see if someone had figured how to get the waver to take weapon or some other solution. I see no progress.
                          Last edited by NannaJoy; 12-01-2010, 05:08:53.

                          Comment


                          • #28
                            so apparently you have to get another person to play the other character in the game for you?
                            sigpic

                            Comment


                            • #29
                              You HAVE to have someone else play the other character for you. On the front screen, it says:

                              友だちと力を合わせて脱出しよう!

                              Translation: Match power and a friend to escape!

                              このゲームは1人ではクリアでいないよ!

                              Translation: This game CANNOT be completed by one person!

                              Here is a video walkthrough:

                              http://www.youtube.com/watch?v=WvtY74cG0Y0

                              On the front screen, the third button, "パスワード" says "Password" - that is what the second player presses.
                              Last edited by tosiaki; 01-16-2011, 18:05:19.

                              Comment


                              • #30
                                Thanks for the info tosiaki!

                                Comment

                                Working...
                                X