1 of 2 < >

Help with downloadable games

If a downloadable game is an .exe file, just click the link, and choose open. The game will usually be installed among your other programs (otherwise you can choose where you would like to install it during the installation process).

If the game is a .zip or .rar file, choose save, and save it to your pc.
Extract it in a new folder using WinRar for example (if you don't have it, get it from here:
Then click the installation file (in most cases .exe file) or the file that starts the game, and your pc will install it, or launch it respectively.
2 of 2 < >

Rules updated

Old members and new members, please read the updated rules.
You find them as sticky at the top of all forum categories, for example here:
Thank you for taking a couple of minutes to do that.

The moderation team
See more
See less

Forum Upgrade: Post Here About Problems/Bugs

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    I don't really know dear Mistery, it seems that it's from Gamershood 'cuz I tried the button on the top right corner where it says: "connect" and whenever I click "Link Accounts" it gives me either what I told you, or sometimes even this: The following errors occurred during your registration

    * A required field called Gender is missing or has an invalid value.
    * Could not find phrase 'Upload failed due to failure writing temporary file.'.

    EDIT: Okay, thank you Mistery!
    Last edited by Hitman; 08-02-2010, 21:56:12.
    Happy endings are just unfinished stories...


    Elite member of the Looney Bin with ex wife "SimplyCrazy" and on-line kids "Wirodeu, Bread ...and Rannei"



    • #62
      Thanks for making us aware of this bug Pandaman

      I've sent a PM to GamersHood with all the info about the bug, and also the workaround/fix info. Please be patient until he can take care of it, thank you

      Our favorite Big Turtle has apparently fixed the issue, please let us know if you still experience any problems with it
      Thanks GamersHood for the fast fix


      • #63
        A update report, I forgot to check the remember me option and the following message came when i tried to post.

        The following errors occurred with your submission
        You do not have permission to perform this action. Please refresh the page and login before trying again.

        It seems that the upgrade for the site hasn't cured all problems, as you can see i still can post but just reporting as Mistery asked me.


        • #64
          So you're saying you can't post when you're not logged in? Cuz that's normal. (Sorry, not up to date on all of this, and Mistery isn't around at the moment.) Or are you saying that you were timed out in less than 15 minutes again?

          EDIT: Just re-read the previous posts on this issue. I assume this is the same issue you were having earlier? I'll let Gamershood know. Thanks for telling us.


          • #65
            Dear GamersHood Members and Guests

            We apologize for the short downtime while the forums have been upgraded.

            It appears that the profile customizations are back again with this update. However, we are also aware that currently it's not possible to change profile pictures, avatars and probably signature images. These issues will be fixed asap.

            If you notice any other glitches or problems, please post here, and we'll take care of them.
            Thanks for your understanding, and enjoy the games and chatting with your online friends

            ~ GamersHood Staff

            The avatar, profile picture, and signature picture issues have been fixed.